cockroachDB feature request: GUI for RDBMS

hello - total newbie here. i have not installed cockroach-db yet, but quickly fell in love with it as soon as i saw the words “FOREIGN KEY”.

my question: is there a webpage interface into the data like rethinkDB and firebase has? both of these turn your data into a giant JSON tree that can be edited in the webpage interface.

maybe my very first newbie question was just too poorly researched before i asked, and i apologize for that.

  1. UI interface: i found this:
    https://www.cockroachlabs.com/docs/start-a-local-cluster.html
    step four: “open an admin ui”

  2. data editing
    it appears that any posgresql option will work. i have been using mysql-workbench for years, so i will investigate a suitable replacement. however, i still look forward to using a possible website data editor like rethinkdb and firebase offers.

@edwardsmarkf

Could you share a little more about your use case for a web-based data editor - amount of data you’re storing/using, what you need to do with it, etc.? It’s not something that’s currently on our roadmap, but we’re certainly open to exploring it.

And if you pick a good mysql-workbench alternative, would love to hear how it works for you.

hmmm i am getting the impression that mariadb(mysql) gui tools are more popular than anything available for PostgreSQL.

however, just the cockroachdb “cool-factor” alone seems to compensate for not using mysql-workbench anymore, unless somebody knows of a good drop-in replacement for mysql-workbench. i might ask this on stack-overflow (and risk being down-voted)

Hey, @edwardsmarkf! –– Would something like Postico suffice for what you’re looking for? Only difference between what you’d use for Postgres vs. using Cockroach is using port 26257

Postico - probably would work ! i have never looked at it but defintely will once i have cockroachDB installed after we are done with the feasibility study (and cockroachDB wins :wink:

If there are any questions we can help answer for the feasibility study, don’t hesitate to ask! We’re still in beta but inching toward 1.0.

Best,
Sean

Executing queries and browse data in dashboard would be nice for tinkering and some quick inspection of the data in the database.

i found this one very recently: http://dbeaver.jkiss.org/ - has anybody tried it?

with mariadb/mysql i continue to use mysql-gui-workbench and i am still looking for something very similar to use with cockroachdb in the future.

@edwardsmarkf I was able to get DBeaver connected using the generic Postgres driver, but discovered we have a compatibility issue with tables containing >200 rows. My guess is that how they’re counting rows or using a LIMIT clause is something Postgres supports that we don’t.

1 Like

Hi @Sean,

Thanks for giving DBeaver a shot. If you have any more details on the compatibility issue, such as logs or expected and actual output, could you please add them to this thread so we can better diagnose the issue?

Thanks,
Jordan

1 Like

Hey @jordan –– attached is a screenshot of the error from DBeaver:

Let me know if you want me to swing by and show you the error.

lets see what they have to say about it. https://github.com/serge-rider/dbeaver/issues/1403

The issue is on our side. We do not support row count limits in pgwire yet: https://github.com/cockroachdb/cockroach/issues/4035

their reply:

I think option “Use SQL to limit results” was turned on. It is off by default. DBeaver uses LIMIT to read data only if this option is on.

@edwardsmarkf Great! That worked for me. Poking around in this for a minute also lets me filter, etc.

1 Like

this sounds like fantastic news. IMHO, any worthwhile database needs a good gui interface. the cli is great of course, but it can be much quicker to use a good gui.

I am unable to connect cockroachDB with DBeaver. Could you please share steps and config details.

Create a PostgreSQL (Generic) connection using this info:

  • Host: localhost (or the host where you’re running Cockroach)
  • Port: 26257 (or the port you’re running it on)
  • Database/Schema: The database you want to open by default (optional)
  • User name: root (or whatever username you chose)
  • Password: Leave this field empty

Also, it’s important to note that I haven’t tried doing this on a secure deployment.

Let me know if that works!

I am running cockroachDB on codeanywhere.com. here are my server settings

I am getting this error