cockroachDB feature request: GUI for RDBMS

@edwardsmarkf I was able to get DBeaver connected using the generic Postgres driver, but discovered we have a compatibility issue with tables containing >200 rows. My guess is that how they’re counting rows or using a LIMIT clause is something Postgres supports that we don’t.

1 Like

Hi @Sean,

Thanks for giving DBeaver a shot. If you have any more details on the compatibility issue, such as logs or expected and actual output, could you please add them to this thread so we can better diagnose the issue?

Thanks,
Jordan

1 Like

Hey @jordan –– attached is a screenshot of the error from DBeaver:

Let me know if you want me to swing by and show you the error.

lets see what they have to say about it. https://github.com/serge-rider/dbeaver/issues/1403

The issue is on our side. We do not support row count limits in pgwire yet: https://github.com/cockroachdb/cockroach/issues/4035

their reply:

I think option “Use SQL to limit results” was turned on. It is off by default. DBeaver uses LIMIT to read data only if this option is on.

@edwardsmarkf Great! That worked for me. Poking around in this for a minute also lets me filter, etc.

1 Like

this sounds like fantastic news. IMHO, any worthwhile database needs a good gui interface. the cli is great of course, but it can be much quicker to use a good gui.

I am unable to connect cockroachDB with DBeaver. Could you please share steps and config details.

Create a PostgreSQL (Generic) connection using this info:

  • Host: localhost (or the host where you’re running Cockroach)
  • Port: 26257 (or the port you’re running it on)
  • Database/Schema: The database you want to open by default (optional)
  • User name: root (or whatever username you chose)
  • Password: Leave this field empty

Also, it’s important to note that I haven’t tried doing this on a secure deployment.

Let me know if that works!

I am running cockroachDB on codeanywhere.com. here are my server settings

I am getting this error

My guess is that it’s an issue with the way you’re able to access CockroachDB from your local machine through codemyapp.

When you start your CockroachDB cluster, you could try setting the --host value to the codemyapp.com URL you’re using in the Host field.

Just wanted to add to this thread – both of these applications look very promising for CockroachDB:

I haven’t gotten either to connect to a local CockroachDB yet. (Though I’m very new to this, so maybe someone who knows what they’re doing can take a look.)

Sqlectron seems like the most likely to be able to fully support CockroachDB in its current state, and it seems to have lots of active contribution.

Hi @bitjson,

Thanks for your interest! I tried both of the programs you mentioned myself, and indeed both have some issues.

DBGlass seems to assume that all tables live in the public schema, which is not true in CockroachDB (nor in PostgreSQL).

Sqlectron requires that the information_schema.routines table be available in order to start a connection. We don’t implement that table yet. It might take a little while before we get to implementing it, because we already implement pg_catalog.pg_proc, which is the PostgreSQL equivalent of this table, and so far, we haven’t seen any other applications that require it.

There may be more issues besides that - these are just the first ones that cropped up.

For now, I suggest using Postico or DBeaver, both of which have seen some limited success.

Thank you,
Jordan Lewis

2 Likes

the rows data seems can’t be alter within DBeaver

there is a debate currently raging in the MariaDB community about the use of mysql-gui-workbench (and no i didn’t start that debate). the MariaDB people seem to have very passionate and yet conflicting opinions about it.

EDIT: some of them in the pro-GUI camp are throwing around the name HeidiSQL.

Don’t get your thread talking , but i tryed heidisql i uses it for postgre ,it failed to connect crockroachDB

Can not find a working Gui for Cockroach, I have some request to have a Gui.
Extending the management Gui would be fine.

@lucevers Postico works. More GUIs will be supported with CockroachDB 2.1. There is an active thread discussing that here

Hi All,

Dbeaver 5.2.0 beta (https://dbeaver.io/files/ea/) now works with Cockroach. Please give it a go and let us know what you think! If you run into any issues you can let me know (andy@cockroachlabs.com).

Andy

1 Like