Deploy cockroachdb behind traefik

Hi.

How can I change the default URL for the DB Console admin webpage?

Instead of the https://host:8080, how can I make it https://host/db-console for example?

I’m hosting it behind a reverse proxy (Traefik), and as soon as I reach the correct URL, it redirects to the host:8080 URL which goes into infinite redirects, and fails to load.

Any way to configure the DB Console path and URL prefix?

Thanks.

Hi @naderelshehabi. Sorry for the delayed response, this one slipped between the cracks. The closest option is --http-addr, which lets you set the host and port that the DB console webpage is hosted on. If you wanted to host it on port 443, that you make it available at like https://host. However, I don’t think there’s an option to change the URL at which it’s hosted. As I think you’re suggesting, you could configure this in your reverse proxy. I don’t understand why there’s an infinite redirect, though; are you saying that the CockroachDB DB console is redirecting you to itself?

Hi Nader,

I also see that you were able to get a response to this same question on the other channel you posted, here: DB Console returns 502 Bad Gateway error behind reverse proxy · Issue #65598 · cockroachdb/cockroach · GitHub

I hope that was the information you were looking for.

Best wishes,
Lisa