Error when importing data into free tier cluster

,

Hey team!

I’ve created a database in Cockroach Cloud free tier and would like to run an IMPORT statement against it using a file that I’m exposing via ngrok.

I’ve run the same command against an identical table using cockroach demo --empty --nodes 1 and it worked fine but when I run against the free tier cloud cluster, I receive the following error:

ERROR: fake protectedts.Provider

Should I be able to do this, or is there a setting in the free tier that’s preventing the use of IMPORTS? I’ve also tried with the file in S3 but receive the same error.

Cheers all :slight_smile:

Rob

Hey @robreid,

This is a known limitation of IMPORT INTO on the current free tier version (21.1), but has been resolved in our next release (21.2). So as soon as the free tier is rolled over you should no longer run into this.

For the time being, would you be able to use IMPORT TABLE instead - IMPORT | CockroachDB Docs. This allows you to create your table and import data into it using a single SQL query.

Apologies for the inconvenience, we are actually deprecating IMPORT TABLE and recommending use of IMPORT INTO so you were doing the right thing!! Hopefully, you can go back to this soon :slightly_smiling_face:

Hey @adityamaru, thanks for your quick response and help!

Yep, that’s no problem at all, thanks again :slight_smile: