error while deploying a django-app using CockroachDB on heroku

I am facing an issue while deploying a django webapp which uses CockroachDB to heroku.
Help :cry:
Exception: Unable to determine CockroachDB version from version string ‘PostgreSQL 13.4 (Ubuntu 13.4-1.pgdg20.04+1) on x86_64-pc-linux-gnu, compiled by gcc (Ubuntu 9.3.0-17ubuntu1~20.04) 9.3.0, 64-bit’.

Hi @manan2110 welcome to the forum!

This error should only happen if you are connecting to a PostgreSQL database, and not a CockroachDB database.

Can you share:

  • How did you set up the CockroachDB cluster?
  • What is the connection string and settings you are using to connect to CockroachDB from Django?