Fails to start cluster on local machine (secure)

Hello,
I am trying to run my first cockroachdb cluster on my local machine. I am using WSL/Ubuntu.

I have installed cockroachdb according to this tutorial:
https://www.cockroachlabs.com/docs/v20.2/install-cockroachdb-linux

Then I continued to this tutorial:
https://www.cockroachlabs.com/docs/v20.2/secure-a-cluster.html

I created and generated certificates, but when I get to “Step 2. Start the cluster” I get this error:

$ cockroach start --certs-dir=certs --store=node1 --listen-addr=localhost:26257 --http-addr=localhost:8080 --join=localhost:26257,localhost:26258,localhost:26259 --background

E210123 13:57:31.012848 1 cli/error.go:398  ERROR: cannot dial server.
Is the server running?
If the server is running, check --host client-side and --advertise server-side.

listen unixgram /tmp/sdnotify069946849/notify.sock: setsockopt: invalid argument
ERROR: cannot dial server.
Is the server running?
If the server is running, check --host client-side and --advertise server-side.

listen unixgram /tmp/sdnotify069946849/notify.sock: setsockopt: invalid argument
Failed running "start"

Any idea what can cause this problem? Thanks for taking your time.

Hi @drogo681 ! Does the error still happen if you do not use the --background flag?

1 Like

Yes, that solved the issue. Thanks!

Great! In general, we don’t test with WSL, so there may be other unexpected problems. Take a look at 12755.