Flyway 5.0.7 not working with Cockroach DB v. 2.0

This is my scenario.

Cockroach DB Verions = 2.0
Flyway Version = 5.0.7
Platform = Docker

I have a java app that uses flyway to manage my schemas.

my flyway build.gradle looks like:

buildscript {
dependencies {
    classpath "org.postgresql:postgresql:42.1.4"
 }
}
 plugins {
     id "org.flywaydb.flyway" version "5.0.7"
 }

description = "test-app"

flyway {
    url = jdbc:postgresql://localhost:26257/test_dev?sslmode=disable
    user = root
    password = 
}

Im running cockroach v 2.0 in insecure mode on my localhost.

When i run:

gradle flywayClean

i get

Flyway upgrade recommended: CockroachDB 2.0 is newer than this version of Flyway and support 
has not been tested.
Unable to clean unknown schema: "test_dev"

When i run:

gradle flywayMigrate

i get:

Database: jdbc:postgresql://localhost:26257/test_dev (PostgreSQL 9.5)
Flyway upgrade recommended: CockroachDB 2.0 is newer than this version of Flyway and support has not been tested.
Creating schema "test_dev" ...
Creating schema "test_dev" ...
Creating schema "test_dev" ...
Creating schema "test_dev" ...
Creating schema "test_dev" ...
Creating schema "test_dev" ...
Creating schema "test_dev" ...
Creating schema "test_dev" ...
Creating schema "test_dev" ...
Creating schema "test_dev" ...

:test-migrations:flywayMigrate (Thread[Task worker for ':',5,main]) completed. Took 19.995 secs.

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':test-migrations:flywayMigrate'.
> Error occurred while executing flywayMigrate

  Unable to create schema "test_dev"
  --------------------------------------------------
  SQL State  : 42P04
  Error Code : 0
  Message    : ERROR: database "test_dev" already exists

  ERROR: database "test_dev" already exists

What could i be missing here?

Postgresql is not 100% compatible, especially migration frameworks access a lot of internal tables, therefore it is quite likely that a migration framework wont support cockroachdb. I had recently also problems with my migration framework driver for crdb, since they changed in v2 their internal tables again. See https://github.com/cockroachdb/cockroach/issues/24472

So you will have to contact the FlyWay authors instead, to release a cockroachdb driver.