IMPORT PGDUMP schema error

When I’m trying to use:

IMPORT PGDUMP 'nodelocal://1/backup.sql'

file that includes schemas, I got an error:
ERROR: unimplemented: non-public schemas unsupported: dev
SQLSTATE: 0A000
HINT: You have attempted to use a feature that is not yet implemented.
See: https://go.crdb.dev/issue-v/26443/v20.2

But my cockroach version is already 20.2!
[root@roach1 extern]# cockroach version
Build Tag: v20.2.0
Build Time: 2020/11/09 16:01:45
Distribution: CCL
Platform: linux amd64 (x86_64-unknown-linux-gnu)
Go Version: go1.13.14
C Compiler: gcc 6.3.0
Build Commit ID: 150c5918fb6e28e0ea5bfa4e8e94088986fbbf98
Build Type: release

Have you supported user defined schema in 20.2 but didn’t support migrating postgres backups including user defined schemas?

Hi pbakiewicz,

I’m an engineer who worked on the user-defined schemas project. Thanks for alerting us to the PGDUMP incompatibility. It does seem to be the case that in the implementation of the feature we missed several integration points with IMPORT PGDUMP. I will work to make sure those get fixed for upcoming releases. I can’t make promises with regards to backporting them to the 20.2 release branch depending on the scale of the change. I’ll make an issue for what I discover later today.

Best,
Andrew

1 Like

We’ve created #56659 to track the issues.