It won't even start

Hello,

I’m having trouble even starting the first node on insecure node. The instructions seem simple enough.

I can’t make sense of the log. Any help is greatly appreciated.

My System Info:
openSUSE 42.2
Kernel:4.4.70-18.9-default

Cockroach:
Build Tag: v1.0.2
Build Time: 2017/06/15 12:58:59
Distribution: CCL
Platform: linux amd64
Go Version: go1.8.3
C Compiler: gcc 6.3.0
Build SHA-1: 9e3606bd2863ce7a460fd0c842414673d62f0533
Build Type: release


Log

W170621 18:50:07.339420 1 cli/start.go:587  RUNNING IN INSECURE MODE!

- Your cluster is open for any client that can access localhost.
- Any user, even root, can log in without providing a password.
- Any user, connecting as root, can read or write any data in your cluster.
- There is no network encryption nor authentication, and thus no confidentiality.

Check out how to secure your cluster: https://www.cockroachlabs.com/docs/secure-a-cluster.html
I170621 18:50:07.339806 1 cli/start.go:593  CockroachDB CCL v1.0.2 (linux amd64, built 2017/06/15 12:58:59, go1.8.3)
I170621 18:50:07.440296 1 server/config.go:281  available memory from cgroups (8.0 EiB) exceeds system memory 16 GiB, using system memory
I170621 18:50:07.440368 1 server/config.go:375  system total memory: 16 GiB
I170621 18:50:07.440514 1 server/config.go:377  server configuration:
max offset                   500ms
cache size                   3.9 GiB
SQL memory pool size         3.9 GiB
scan interval                10m0s
scan max idle time           200ms
consistency check interval   24h0m0s
metrics sample interval      10s
time until store dead        5m0s
send next timeout            500ms
event log enabled            true
linearizable                 false
I170621 18:50:07.440737 14 cli/start.go:340  starting cockroach node
W170621 18:50:07.446741 14 server/config_unix.go:106  soft open file descriptor limit 4096 is under the recommended limit 15000; this may decrease performance
please see https://www.cockroachlabs.com/docs/recommended-production-settings.html for more details
I170621 18:50:07.446935 14 storage/engine/rocksdb.go:380  opening rocksdb instance at "/home/paul/cockroach-data"
SIGILL: illegal instruction
PC=0x16ac02b m=10 sigcode=2
signal arrived during cgo execution

goroutine 14 [syscall, locked to thread]:
non-Go function
        pc=0x16ac02b
non-Go function
        pc=0x15e3498
runtime.cgocall(0x14b0760, 0xc42058ec00, 0xc42058ec70)
        /usr/local/go/src/runtime/cgocall.go:131 +0xe2 fp=0xc42058eb90 sp=0xc42058eb50
github.com/cockroachdb/cockroach/pkg/storage/engine._Cfunc_DBOpen(0xc420340580, 0xc4201b2880, 0x19, 0x7f37bce0d010, 0x8000, 0x0, 0x400000000, 0xf00, 0x0, 0x0)
        github.com/cockroachdb/cockroach/pkg/storage/engine/_obj/_cgo_gotypes.go:565 +0x5d fp=0xc42058ec00 sp=0xc42058eb90
github.com/cockroachdb/cockroach/pkg/storage/engine.(*RocksDB).open.func1(0xc420340580, 0xc4201b2880, 0x19, 0x7f37bce0d010, 0x8000, 0x0, 0x400000000, 0xf00, 0x0, 0x0)
        /go/src/github.com/cockroachdb/cockroach/pkg/storage/engine/rocksdb.go:405 +0x1a1 fp=0xc42058eca8 sp=0xc42058ec00
github.com/cockroachdb/cockroach/pkg/storage/engine.(*RocksDB).open(0xc420340580, 0xc4201b2580, 0x1d)
        /go/src/github.com/cockroachdb/cockroach/pkg/storage/engine/rocksdb.go:405 +0x37d fp=0xc42058ee00 sp=0xc42058eca8
github.com/cockroachdb/cockroach/pkg/storage/engine.NewRocksDB(0x0, 0x0, 0x0, 0xc4203b8160, 0x19, 0x7f37bce0d000, 0x0, 0xf00, 0x10, 0x0, ...)
        /go/src/github.com/cockroachdb/cockroach/pkg/storage/engine/rocksdb.go:346 +0x203 fp=0xc42058ee90 sp=0xc42058ee00
github.com/cockroachdb/cockroach/pkg/server.(*Config).CreateEngines(0xc420202488, 0x7f37c395f5d8, 0xc42047c9f0, 0x0, 0x0, 0x0, 0x0, 0x0)
        /go/src/github.com/cockroachdb/cockroach/pkg/server/config.go:466 +0xd09 fp=0xc42058f2a0 sp=0xc42058ee90
github.com/cockroachdb/cockroach/pkg/server.(*Server).Start(0xc420202480, 0x7f37c395f5d8, 0xc42047c9f0, 0xc42001a540, 0x1)
        /go/src/github.com/cockroachdb/cockroach/pkg/server/server.go:637 +0xd77 fp=0xc42058f890 sp=0xc42058f2a0
github.com/cockroachdb/cockroach/pkg/cli.runStart.func1.1(0x7f37c395f5d8, 0xc42017a0f0, 0xc4203bc1f8, 0xc4204d4820, 0xc42017fae0, 0x0, 0x0)
        /go/src/github.com/cockroachdb/cockroach/pkg/cli/start.go:359 +0x210 fp=0xc42058ff48 sp=0xc42058f890
github.com/cockroachdb/cockroach/pkg/cli.runStart.func1(0x7f37c395f5d8, 0xc42017a0f0, 0x2791ba0, 0x2c34368, 0xc4203bc1f8, 0xc4204d4820, 0xc42017fae0, 0xc4205e62a0)
        /go/src/github.com/cockroachdb/cockroach/pkg/cli/start.go:416 +0xdf fp=0xc42058ffa0 sp=0xc42058ff48
runtime.goexit()
        /usr/local/go/src/runtime/asm_amd64.s:2197 +0x1 fp=0xc42058ffa8 sp=0xc42058ffa0
created by github.com/cockroachdb/cockroach/pkg/cli.runStart
        /go/src/github.com/cockroachdb/cockroach/pkg/cli/start.go:419 +0x3e0

goroutine 1 [select]:
github.com/cockroachdb/cockroach/pkg/cli.runStart(0x2760300, 0xc42017a060, 0x0, 0x3, 0x0, 0x0)
        /go/src/github.com/cockroachdb/cockroach/pkg/cli/start.go:428 +0xe2c
github.com/cockroachdb/cockroach/pkg/cli.MaybeDecorateGRPCError.func1(0x2760300, 0xc42017a060, 0x0, 0x3, 0xc42069fc90, 0x14a1dd8)
        /go/src/github.com/cockroachdb/cockroach/pkg/cli/error.go:35 +0x5a
github.com/cockroachdb/cockroach/pkg/cli.MaybeShoutError.func1(0x2760300, 0xc42017a060, 0x0, 0x3, 0x0, 0x0)
        /go/src/github.com/cockroachdb/cockroach/pkg/cli/error.go:66 +0x51
github.com/cockroachdb/cockroach/vendor/github.com/spf13/cobra.(*Command).execute(0x2760300, 0xc4201a3f80, 0x3, 0x3, 0x2760300, 0xc4201a3f80)
        /go/src/github.com/cockroachdb/cockroach/vendor/github.com/spf13/cobra/command.go:644 +0x3f8
github.com/cockroachdb/cockroach/vendor/github.com/spf13/cobra.(*Command).ExecuteC(0x275c880, 0x5c606e, 0xc42001a270, 0xc42069ff10)
        /go/src/github.com/cockroachdb/cockroach/vendor/github.com/spf13/cobra/command.go:734 +0x339
github.com/cockroachdb/cockroach/vendor/github.com/spf13/cobra.(*Command).Execute(0x275c880, 0xc42069ff00, 0xc42001a240)
        /go/src/github.com/cockroachdb/cockroach/vendor/github.com/spf13/cobra/command.go:693 +0x2b
github.com/cockroachdb/cockroach/pkg/cli.Run(0xc420010150, 0x4, 0x4, 0xc4200165f0, 0xc4200165f0)
        /go/src/github.com/cockroachdb/cockroach/pkg/cli/cli.go:136 +0x6d
github.com/cockroachdb/cockroach/pkg/cli.Main()
        /go/src/github.com/cockroachdb/cockroach/pkg/cli/cli.go:51 +0x17f
main.main()
        /go/src/github.com/cockroachdb/cockroach/main.go:28 +0x20

goroutine 17 [syscall, locked to thread]:
runtime.goexit()
        /usr/local/go/src/runtime/asm_amd64.s:2197 +0x1

goroutine 5 [chan receive]:
github.com/cockroachdb/cockroach/pkg/util/log.(*loggingT).flushDaemon(0x2bf52a0)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/log/clog.go:1024 +0x77
created by github.com/cockroachdb/cockroach/pkg/util/log.init.1
        /go/src/github.com/cockroachdb/cockroach/pkg/util/log/clog.go:566 +0xd9

goroutine 10 [syscall]:
os/signal.signal_recv(0x3a64643a39323a36)
        /usr/local/go/src/runtime/sigqueue.go:116 +0x104
os/signal.loop()
        /usr/local/go/src/os/signal/signal_unix.go:22 +0x22
created by os/signal.init.1
        /usr/local/go/src/os/signal/signal_unix.go:28 +0x41

goroutine 12 [select, locked to thread]:
runtime.gopark(0x1bc1530, 0x0, 0x1aed773, 0x6, 0x18, 0x2)
        /usr/local/go/src/runtime/proc.go:271 +0x13a
runtime.selectgoImpl(0xc42003ff50, 0x0, 0x18)
        /usr/local/go/src/runtime/select.go:423 +0x1364
runtime.selectgo(0xc42003ff50)
        /usr/local/go/src/runtime/select.go:238 +0x1c
runtime.ensureSigM.func1()
        /usr/local/go/src/runtime/signal_unix.go:434 +0x2dd
runtime.goexit()
        /usr/local/go/src/runtime/asm_amd64.s:2197 +0x1

goroutine 13 [chan receive]:
github.com/cockroachdb/cockroach/pkg/util/log.(*loggingT).gcDaemon(0x2bf52a0)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/log/clog.go:1058 +0x5f
created by github.com/cockroachdb/cockroach/pkg/util/log.StartGCDaemon
        /go/src/github.com/cockroachdb/cockroach/pkg/util/log/clog.go:579 +0x41

goroutine 16 [chan receive]:
github.com/cockroachdb/cockroach/pkg/rpc.NewContext.func1(0x7f37c395f5d8, 0xc420019320)
        /go/src/github.com/cockroachdb/cockroach/pkg/rpc/context.go:176 +0x76
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc420192290, 0xc4204d4820, 0xc4201ee5a0)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 34 [select]:
github.com/cockroachdb/cockroach/pkg/kv.(*TxnCoordSender).printStatsLoop(0xc4205b8750, 0x7f37c395f5d8, 0xc4200197a0)
        /go/src/github.com/cockroachdb/cockroach/pkg/kv/txn_coord_sender.go:253 +0xb4a
github.com/cockroachdb/cockroach/pkg/kv.NewTxnCoordSender.func1(0x7f37c395f5d8, 0xc4200197a0)
        /go/src/github.com/cockroachdb/cockroach/pkg/kv/txn_coord_sender.go:237 +0x3e
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4201926b0, 0xc4204d4820, 0xc4201926a0)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 35 [select]:
github.com/cockroachdb/cockroach/pkg/sql.(*LeaseManager).RefreshLeases.func1(0x7f37c395f5d8, 0xc420019800)
        /go/src/github.com/cockroachdb/cockroach/pkg/sql/lease.go:1240 +0xaf5
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc420192a20, 0xc4204d4820, 0xc420325ef0)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 36 [select]:
github.com/cockroachdb/cockroach/pkg/server.(*Server).refreshSettings.func2(0x7f37c395f5d8, 0xc420374000)
        /go/src/github.com/cockroachdb/cockroach/pkg/server/settingsworker.go:113 +0x38b
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc420192a30, 0xc4204d4820, 0xc4201eed20)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 37 [chan receive]:
github.com/cockroachdb/cockroach/pkg/util/netutil.MakeServer.func2(0x7f37c395f5d8, 0xc4204ec030)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/netutil/net.go:102 +0x70
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4203c71c0, 0xc4204d4820, 0xc42017df60)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 38 [chan receive]:
github.com/cockroachdb/cockroach/pkg/util/netutil.MakeServer.func2(0x7f37c395f5d8, 0xc420325230)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/netutil/net.go:102 +0x70
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4203c7200, 0xc4204d4820, 0xc42017dfa0)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 41 [chan receive]:
github.com/cockroachdb/cockroach/pkg/server.(*Server).Start.func2(0x7f37c395f5d8, 0xc420325410)
        /go/src/github.com/cockroachdb/cockroach/pkg/server/server.go:519 +0x5f
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4203c74a0, 0xc4204d4820, 0xc4200d7360)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 42 [IO wait]:
net.runtime_pollWait(0x7f37c3960638, 0x72, 0x0)
        /usr/local/go/src/runtime/netpoll.go:164 +0x59
net.(*pollDesc).wait(0xc4202c0458, 0x72, 0x0, 0xc4203b8040)
        /usr/local/go/src/net/fd_poll_runtime.go:75 +0x38
net.(*pollDesc).waitRead(0xc4202c0458, 0xffffffffffffffff, 0x0)
        /usr/local/go/src/net/fd_poll_runtime.go:80 +0x34
net.(*netFD).accept(0xc4202c03f0, 0x0, 0x2773160, 0xc4203b8040)
        /usr/local/go/src/net/fd_unix.go:430 +0x1e5
net.(*TCPListener).accept(0xc42000e0a0, 0xc4204ec5a0, 0x1909dc0, 0x2747dd0)
        /usr/local/go/src/net/tcpsock_posix.go:136 +0x2e
net.(*TCPListener).Accept(0xc42000e0a0, 0xc4204ec540, 0x1909dc0, 0x2747dd0, 0x19f4920)
        /usr/local/go/src/net/tcpsock.go:228 +0x49
net/http.(*Server).Serve(0xc4200b1ef0, 0x2784b60, 0xc42000e0a0, 0x0, 0x0)
        /usr/local/go/src/net/http/server.go:2643 +0x228
github.com/cockroachdb/cockroach/pkg/server.(*Server).Start.func5(0x7f37c395f5d8, 0xc4204ec420)
        /go/src/github.com/cockroachdb/cockroach/pkg/server/server.go:542 +0x42
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4203c74b0, 0xc4204d4820, 0xc4200d7380)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 43 [chan receive]:
github.com/cockroachdb/cockroach/pkg/server.(*Server).Start.func6(0x7f37c395f5d8, 0xc4203254a0)
        /go/src/github.com/cockroachdb/cockroach/pkg/server/server.go:546 +0x88
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4203c74c0, 0xc4204d4820, 0xc420346200)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 44 [chan receive]:
github.com/cockroachdb/cockroach/vendor/github.com/cockroachdb/cmux.(*muxListener).Accept(0xc4200d6fa0, 0x1bc0860, 0xc42055b960, 0x2785560, 0xc4200d6fa0)
        <autogenerated>:9 +0x7a
github.com/cockroachdb/cockroach/vendor/google.golang.org/grpc.(*Server).Serve(0xc42055b960, 0x2785560, 0xc4200d6fa0, 0x0, 0x0)
        /go/src/github.com/cockroachdb/cockroach/vendor/google.golang.org/grpc/server.go:396 +0x189
github.com/cockroachdb/cockroach/pkg/server.(*Server).Start.func7(0x7f37c395f5d8, 0xc4202ed440)
        /go/src/github.com/cockroachdb/cockroach/pkg/server/server.go:557 +0x43
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4203c74d0, 0xc4204d4820, 0xc4200d73a0)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 45 [select]:
github.com/cockroachdb/cockroach/pkg/server.(*Server).Start.func9(0x7f37c395f5d8, 0xc420325620)
        /go/src/github.com/cockroachdb/cockroach/pkg/server/server.go:606 +0x2b9
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4203c74f0, 0xc4204d4820, 0xc420346240)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 46 [chan receive]:
github.com/cockroachdb/cockroach/pkg/gossip.(*server).start.func3(0x7f37c395f5d8, 0xc420325590)
        /go/src/github.com/cockroachdb/cockroach/pkg/gossip/server.go:386 +0x66
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4203c7580, 0xc4204d4820, 0xc4200d74c0)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 47 [select]:
github.com/cockroachdb/cockroach/pkg/gossip.(*Gossip).bootstrap.func1(0x7f37c395f5d8, 0xc4204ec660)
        /go/src/github.com/cockroachdb/cockroach/pkg/gossip/gossip.go:1055 +0x49d
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4203c75d0, 0xc4204d4820, 0xc4203c7590)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

goroutine 48 [select]:
github.com/cockroachdb/cockroach/pkg/gossip.(*Gossip).manage.func1(0x7f37c395f5d8, 0xc4202ed4a0)
        /go/src/github.com/cockroachdb/cockroach/pkg/gossip/gossip.go:1093 +0x325
github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker.func1(0xc4203c7610, 0xc4204d4820, 0xc4203c7600)
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:215 +0xf7
created by github.com/cockroachdb/cockroach/pkg/util/stop.(*Stopper).RunWorker
        /go/src/github.com/cockroachdb/cockroach/pkg/util/stop/stopper.go:216 +0xad

rax    0x7f37bcedd028
rbx    0x0
rcx    0x7f37bcedd038
rdx    0x0
rdi    0x7f37bd9fc2e0
rsi    0x0
rbp    0x7f37bd9fc330
rsp    0x7f37bd9fc230
r8     0x7f37c2983040
r9     0x7f37bce8b830
r10    0x33
r11    0x7f37c2983f88
r12    0x0
r13    0x7f37bcedd000
r14    0x0
r15    0x0
rip    0x16ac02b
rflags 0x10246
cs     0x33
fs     0x0
gs     0x0

Our binary releases are compiled for CPUs that have the SSE 4.2 feature set. This SIGILL error is raised when you’re running on a CPU older than that (which I believe means an intel CPU from before 2008, or an AMD CPU from before 2011). CockroachDB can run on older CPUs, but you’ll need to build it yourself from source.

We’d like to make this work better on older CPUs; that is tracked in this issue.

HAHAHA…You are correct! Since I stopped playing games and linux runs great on old hardware, I haven’t seen a reason to upgrade . The only upgrade I have made in 9 years is 16gb ram upgrade to run analytics in R. This is the second time this has happened to me. I tried running TensorFlow with GPU support but I got a message like “NVIDIA 9800GTX are you kidding me!”. The NVIDIA proprietary driver doesn’t even work with the newer kernels.

I will compile from source then.

Thanks :grinning:

I got it working.

One thing. When I did “make install” it did not find go even though it is in the PATH. Go is installed in /usr/local/go/bin/. I made symbolic link from /usr/bin/ to the go binary and it worked. I don’t know if there is a problem with the make script. I installed go from the golang website, maybe the versions from package managers are put in /usr/bin/

Just in case someone else has the same problem

Hmm, are you sure that /usr/local/go/bin/ is on your PATH? That’s not standard—usually only /usr/local/bin is on the PATH.

Yes,

Those are the instructions on the golang website

https://golang.org/doc/install

You’re supposed to add it to the PATH

Right, exactly: you need to manually add /usr/local/go/bin to your PATH.

I’m afraid I can’t reproduce your problem. Here’s a snippet of a shell session on a fresh Ubuntu 16.04 machine that has Go installed from the from the official Linux tarball:

benesch@benesch-test:~/go/src/github.com/cockroachdb/cockroach$ make
GOPATH set to /home/benesch/go
/bin/bash: go: command not found
/bin/bash: go: command not found
build/common.mk:110: *** "go1\.8.* required (see CONTRIBUTING.md): ".  Stop.
benesch@benesch-test:~/go/src/github.com/cockroachdb/cockroach$ PATH=$PATH:/usr/local/go/bin
benesch@benesch-test:~/go/src/github.com/cockroachdb/cockroach$ make
GOPATH set to /home/benesch/go
rm -rf jemalloc.src
...
github.com/cockroachdb/cockroach

As soon as I adjust my PATH, the Makefile is able to find the go binary and produces a successful build.

What was the specific error you were seeing?