Linux building error

I’m trying to build cockroach db from source code under ubuntu.

I’m using go 1.10 version as my compiler, under Ubuntu 16.04.4 LTS.

It keeps give me error build/common.mk:110: *** "go1\.8.* required (see CONTRIBUTING.md): go version go1.10 linux/amd64". Stop.

Right now I am using master branch, have anyone noticed error like this ?

The file build/common.mk does not exist in the master branch any more. I think your branch is not up to date.

@knz it does exists in the latest stable (1.1.5) source tarball release, though based on the line number here, that isn’t quite the version used here.

@jiangfeng Our build scripts constrain the Go version they work with based on the Go features we used and/or tested against for a given release. You have a couple options:

  • You can try using our 2.0 branch (or master), which is not yet released but does support go1.10.

  • More effort but most likely to work would be to actually install the go1.8 toolchain as well now that go makes it somewhat easier to have parallel versions installed.

  • Finally, it may or may not work just to edit the Go version required in .go-version and see it if it just happens to work, though, since that isn’t a configuration we tested with for that release, you may well run into new issues that way.

@david Thank you for your reply. I tried master version later, and modified your makefile, as I think higher go version works just fine, I commented that version check. It builds just fine, would there be any further potentially error?

@knz thank you all the same, I tried master branch.

We’re currently developing and testing with go1.10 on master, so if that’s what you’re using, it should work just fine. Cheers.