Recommended SQLAlchemy version for Cockroachdb v2.1 upgrade

deployment
sql

(Swaroop) #1

Hi,
Planning to upgrade Cockroachdb cluster from 2.0.4 to 2.1.3. Release notes recommends cockroachdb-python adapter to be upgraded to the latest release(0.2.1). Is it also necessary to bump up the SQLAlchemy version from 1.1 to latest? I see for the cockroachdb adapter testing, SQLAlchemy has been bumped up from 1.1 to 1.2.10.


(Raphael 'kena' Poss) #2

SQLAlchemy 1.2 will work, and we have found that some later version of SQLAlchemy may not work properly. (We have not tested further yet.)