Unable to access DB Console

Hi,

I’ve installed CockroachDB on a local VM (Vagrant+VirtualBox). It went find up to this step:
https://www.cockroachlabs.com/docs/v20.2/secure-a-cluster#step-5-access-the-db-console

From my Desktop (local Chrome browser), I can’t access the DB Console running on my VM.
I’ve configured the port forwarding and I can confirm that the port 8080 is listening using a Port scanner.

Any idea?

Thank you,
Luc

Hi Luc,

Are you able to view the logs of the CockrochDB node? If so, do you see a line that starts with webui:?

This sounds like a networking issue, as you suspected. We’ll want to confirm that CRDB is up and running and then explore why you aren’t able to connect from outside of the virtual machine.

Nathan

Hello Nathan,

Yes I do:

vagrant@vagrant:~/node1/logs$ grep webui *.log
cockroach.log:webui:               ‹https://localhost:8080›

And I am forwarding these ports between my host laptop and the guess image:
config.vm.network :forwarded_port, guest: 22, host: 2200, id: ‘ssh’
config.vm.network :forwarded_port, guest: 8080, host: 8080
config.vm.network :forwarded_port, guest: 26257, host: 26257

I am able to SSH to my VM using 127.0.0.1:2200. But from a browser, https://localhost:8080 doesn’t work. I tried from both Chrome and Edge.

From the VM, I can use a curl command, at least I get an answer.

Is there any parameter to set to allow the DB console remotely?
Thank you,

Luc

Hi Luc,

There shouldn’t be a need to set any parameters on the DB if you have port forwarding set up correctly, so let’s try to figure that out. You mention that you can SSH into the VM. Once inside, could you try running curl https://localhost:8080?

Nathan

Hi,

I can curl in insecure mode.

curl https://localhost:8080
curl: (60) SSL certificate problem: unable to get local issuer certificate

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.

curl --insecure https://localhost:8080

Cockroach Console
...

Thank you,

Luc